Home Technical Discussions Audi A6 2005 and later (C6)

Audi A6 2005 and later (C6) 2005 A6 3.2L Cooling fans ON all the time


Permlink Replies: 2 - Pages: 1 Threads: [ Previous | Next ]
Last Post: Oct 15, 2017 12:31 PM Last Post By: tlewis02
martinb

Posts: 4
Registered: 03/23/10
2005 A6 3.2L Cooling fans ON all the time
Posted: Jun 21, 2012 10:39 PM
  Click to reply to this thread Reply
2005 Audi A6 3.2L /85 000km/ My cooling fans stay ON at all times and doesn't matter if the engine is cold or warm.As soon as you start the car they go ON high speed/both fans/ and stop in about 1min after you turn off tthe ignition. No MIL ON , no DTC stored. Replaced the Fan Control Module still the same. Fuses and relays OK. Temperature sensor also OK.On cold start engine warms up as usual and normal to 90 C .
Anybody with similar issue? Help needed?
martinb

Posts: 4
Registered: 03/23/10
Re: 2005 A6 3.2L Cooling fans ON all the time
Posted: Jul 17, 2012 7:44 PM   in response to: martinb in response to: martinb
  Click to reply to this thread Reply
UPDATE : Problem fixed after new ECM (ECU) installed at dealer.

Edited by: martinb on Jul 17, 2012 9:14 PM
tlewis02

Posts: 65
Registered: 03/31/03
Re: 2005 A6 3.2L Cooling fans ON all the time
Posted: Oct 15, 2017 12:31 PM   in response to: martinb in response to: martinb
  Click to reply to this thread Reply
similar issue on our 2008 A6 C6. Everything seems to work fine so I have not bothered with it (plenty of other things, like suspension upgrade, which need my time and attention). However, if I knew the fix I would probably go for it.

Was the ECM the problem, or did you have to replace the ECM anyway and this took care of the problem? Was it a simple flash upgrade or an actual replacment?

ECM replacement seems like more $ than I want to get into. Thanks for any advice!

Tom

Point your RSS reader here for a feed of the latest messages in all forums

Related Products
Popular Discussions:
No popular dicussions.