Home Technical Discussions Audi 90 1993-1995, Cabriolet 1994-1998 (B4)

Audi 90 1993-1995, Cabriolet 1994-1998 (B4) 1995 Cabbie Transmission Electrical Problems


Permlink Replies: 5 - Pages: 1
Last Post: Nov 2, 2015 12:56 PM Last Post By: hubturn
z261994

Posts: 2
Registered: 08/28/08
1995 Cabbie Transmission Electrical Problems
Posted: Aug 29, 2008 10:47 PM
  Click to reply to this thread Reply
This is for an early 1995 Cabriolet with an 097 transmission.

I get the following error codes:

00518 Throttle Position Sensor - Signal Out of Range (G69) Also check for loose ECM power relay.

00293 Multi-Function Transmission Range Switch - Malfunction (PRNDL Input) (F125)

00281 Vehicle Speed Sensor - No Signal (G68 )

00638 Engine/Transmission Electrical Connection 2. Also check for loose ECM power relay.

I can manually shift 1st to 3rd and reverse works fine. Upon startup, the gear indicator in the dash flashes neutral for a second and then stays in park until I shut the car off.

I replaced the Multifunction switch already and that didn't change anything at all.

My next plan of attack is either going to be the VSS or TCM. I'm trying to figure out if the VSS on the transmission is a powered sensor (got a manual on CD yesterday, but having a LOT of difficulty installing it... not happy, and whole differnent story altogether). I had the codes scanned and then cleared. I started the car and then, without ever moving the car, scanned the codes again. The VSS code came up again, which shouldn't happen unless the VSS is powered. If it's not powered, it could be completely unplugged and not throw a code until the trans tries to shift. If it's a passive sensor then the TCM is screwing up and causing a false code.

I'm just looking for some input here. Thanks in advance for any help!

avi

Posts: 84
Registered: 08/27/04
Re: 1995 Cabbie Transmission Electrical Problems
Posted: Sep 1, 2008 1:44 AM   in response to: z261994 in response to: z261994
  Click to reply to this thread Reply
hi mate,
i know a thing or two on this tranny..
firs i can supply you with a full rebuid pdf if you give me your mail address.
but from what i read here you have a loom problem which means you need to take it of the car and fix or replace with a good tested one.
best regards,
avishay.
z261994

Posts: 2
Registered: 08/28/08
Re: 1995 Cabbie Transmission Electrical Problems
Posted: Sep 1, 2008 12:45 PM   in response to: z261994 in response to: z261994
  Click to reply to this thread Reply
I would really apppreciate the rebuild info, my email address is:

By "loom problem" is that the entire transmission wiring harness? First Audi for me, so I'm still getting used to the terminology... I've always owned GM's before.

Thank you

Edited by: z261994 on Nov 2, 2015 12:56 PM

uweA

Posts: 1
Registered: 12/21/08
Re: 1995 Cabbie Transmission Electrical Problems
Posted: Dec 21, 2008 12:58 AM   in response to: z261994 in response to: z261994
  Click to reply to this thread Reply
1994/95 AUDI Cab transmissions per AUDI America and its CA Dealers ( all of them I called) Were told by Audi, Tranny cannot be adequately repaired and must be replaced by a German factory replacement. Since the car had approx. 20K miles , the cars Automatic Tranny started to hesitate in fourth gear and later also in 3rd Gear,the Dealer changed Motor Mounts as well as all the mounts. I later found out that the Dealers were told to not target the transmission by AUDI. At 40K the Tranny really started to act up, it would hesitate to engage the 4th gear and when excellerating it suddenly would engage like a sling shot. dealer again gave it the Sunshine treatment, finally the engine had to be rebuilt for a different reason, Dealer did not replace the rear Seal and after another 5500 Miles the Seal started to leak. The Steering Box also started to leak , obviously a casulty of removing the Engine, the radiator also was kicked by the engine and needed to be replaced next.
Meanwhile AUDI had replaced all of the rubber around the Tranny one more time.
The special Steering Fluid believe it or not is made by VW and available in the same bottle at all VW Parts Places at lower prices , non of the Non specialized parts Houses have it.
AUDI was aware that the Transmission was a Factory problem , no recall "Mum was the word " A crime yes!
I now have a Replacement 1955 tranny FOR SALE that I bought from a east Coast Rebuilder , my car has so many issues that I will sell it cheap as well. never ever will I buy another AUDI and I am german born ! Contact me if you need the Tranny or body parts etc.
JBull

Posts: 1
Registered: 05/20/09
Re: 1995 Cabbie Transmission Electrical Problems
Posted: May 20, 2009 5:41 PM   in response to: uweA in response to: uweA
  Click to reply to this thread Reply
This is a long shot considering you posted this five months ago, but do you still have that Audi? I'm looking for body panels for my 95 Cabriolet.
hubturn

Posts: 29
Registered: 04/07/06
Re: 1995 Cabbie Transmission Electrical Problems
Posted: May 20, 2009 10:13 PM   in response to: JBull in response to: JBull
  Click to reply to this thread Reply
toosonny@hotmail.com is parting a '95 and '97. He is on audiworld forums

Point your RSS reader here for a feed of the latest messages in all forums

Popular Discussions:
No popular dicussions.