Home Technical Discussions BMW E39 5 Series 1997-2003 (525i, 528i, 540i, M5,...

BMW E39 5 Series 1997-2003 (525i, 528i, 540i, M5, sport wagon) ASC, ABS, CE, transmission won't upshift.


Permlink Replies: 6 - Pages: 1
Last Post: Mar 14, 2011 3:30 AM Last Post By: Hasso
dwis

Posts: 9
Registered: 06/21/06
ASC, ABS, CE, transmission won't upshift.
Posted: Dec 29, 2010 1:03 AM
  Click to reply to this thread Reply
I have a 98 528i. All at once the ABS and ASC light came on and the transmission failed to shift into overdrive automatically. The check engine light has come on and there are no codes to be read. I have swapped the rear ABS sensors and it did not fix the shifting issue. I have also disconnected the ABS unit with no results. Do I need to replace my ABS control unit? I have the one that ModuleMasters can't rebuild. I don't want to throw that much money at it if I'm missing something.
Hasso

Posts: 503
Registered: 12/09/03
Re: ASC, ABS, CE, transmission won't upshift.
Posted: Feb 11, 2011 2:26 AM   in response to: dwis in response to: dwis
  Click to reply to this thread Reply
The problem with shifting gears is a front wheel sensorproblem and also a small differance of tyrewere/size on the same axel make this problem comes up. Also wrong/to much differnet diameter of front and rear wheels also give this gearshiftning /ASCproblem. there is only a 5% limit.
There should always be faultycodes when the ABS/ASC light is on
dwis

Posts: 9
Registered: 06/21/06
Re: ASC, ABS, CE, transmission won't upshift.
Posted: Feb 18, 2011 2:29 PM   in response to: Hasso in response to: Hasso
  Click to reply to this thread Reply
I have switched the sensors on the front and the front left still reads about half the RPMs on INPA. That eliminates the sensor as the problem. I guess that only leaves the wheel bearing or the ASC unit. Is there another possible culprit. I plan on changing the bearing and if that doesn't fix it, replacing the ABS computer. Is there something else I should look at?
jazzsaxman

Posts: 60
Registered: 05/15/07
Re: ASC, ABS, CE, transmission won't upshift.
Posted: Feb 18, 2011 3:35 PM   in response to: dwis in response to: dwis
  Click to reply to this thread Reply
What happens when you reset the fault codes and turn on the ignition. If the lights are not on after reset then come on after you drive away it will be a fault with the sensor or wheel bearing. If you turn on the ignition and the fault is there right away then it could be the wiring or the sensor but as you have replaced the sensor look elsewhere. When my sensor was playing up, my gearbox would change up, but only as high a third gear. I had to select semi auto to manually change up the gear but once I changed the sensor it worked a treat and Hasso was the man who pointed me in the right direction. He is top dog.
dwis

Posts: 9
Registered: 06/21/06
Re: ASC, ABS, CE, transmission won't upshift.
Posted: Mar 5, 2011 5:11 PM   in response to: jazzsaxman in response to: jazzsaxman
  Click to reply to this thread Reply
I have replaced the ASC module and coded it with progman, no change. The sensors are working, the ASC is working, but INPA still reports the left front at about half the rpm of the other tires. There must be another computer in the mix that is causing this. What else is in line? Any help is appreciated.
dwis

Posts: 9
Registered: 06/21/06
Re: ASC, ABS, CE, transmission won't upshift.
Posted: Mar 12, 2011 7:59 PM   in response to: dwis in response to: dwis
  Click to reply to this thread Reply
I have now replaced both front wheel sensors and a new problem has come up. There is now only intermittent contact with the control module on INPA. Turning off the car will allow reconnection, but it will only last about a minute. I don't know how information flows through the different computers, but I can only imagine this should narrow down the problem module. Any help is greatly appreciated.
Hasso

Posts: 503
Registered: 12/09/03
Re: ASC, ABS, CE, transmission won't upshift.
Posted: Mar 14, 2011 3:30 AM   in response to: dwis in response to: dwis
  Click to reply to this thread Reply
Where do you buy the sensors ?? BMW genuine ?? or OEM. There seems to be a problem all over the world with OEM sensors from independed sparepartdealers, and give owners more headache and problem, there is also differnet sensors before and after 09/98.
And why change a working sensor on right, its proberly better you change the wheelbearing on front left there you have the problem instead of changing part how works it only make things more difficult to trobleshoot. Where do you get the ABS/ASC module from new or used ??

Point your RSS reader here for a feed of the latest messages in all forums

Popular Discussions:
No popular dicussions.