Home Technical Discussions Audi TT 2000-2006

Audi TT 2000-2006 total electrical failure


Permlink Replies: 3 - Pages: 1
Last Post: Oct 11, 2008 11:45 AM Last Post By: redline
maldives

Posts: 1
Registered: 12/26/07
total electrical failure
Posted: Dec 26, 2007 5:30 AM
  Click to reply to this thread Reply
we have a 2000 audi tt 225bhp. been having problems with dash pod, car has been unused for a couple of days over christmas, all electrics now not working eg dash lights, central locking etc car will not even turn over but battery is fully charged please help!
Erinpurcell

Posts: 1
Registered: 04/12/08
Re: total electrical failure
Posted: Apr 12, 2008 6:17 AM   in response to: maldives in response to: maldives
  Click to reply to this thread Reply
I have exactly the same problem with my TT but Audi are charging 130 an hour just to lok at it! Did you manage to get this resolved?
bike car

Posts: 1
Registered: 10/06/05
Re: total electrical failure
Posted: Oct 1, 2008 7:57 PM   in response to: maldives in response to: maldives
  Click to reply to this thread Reply
Check the battery terminal/fuse block on top of the battery. I had lots of corrosion there. Wiggle each wire. Clean or replace as needed. Common problem.
redline

Posts: 1
Registered: 10/11/08
Re: total electrical failure
Posted: Oct 11, 2008 11:45 AM   in response to: maldives in response to: maldives
  Click to reply to this thread Reply
I now have the same exact problem, how did you resolt it? A million thanks in advance.

Point your RSS reader here for a feed of the latest messages in all forums

Popular Discussions:
No popular dicussions.